Tag Archives: Exchange 2010

#Exchange On-Prem PST Migration zu #Office365

In den letzten Tagen war ich mal mehr in Office 365 unterwegs 😉

FĂŒr eine kleine Umgebung war eine Migration vorhandener PostfĂ€cher eines lokalen Exchange nach Office 365 notwendig. Allerdings sollte die lokale Umgebung aufgelöst und die vorhandenen User in einer neu angelegtem DomĂ€ne innerhalb von Office 365 angelegt und portiert werden. Da es sich um eine kleine Organisation handelt, die primĂ€r Mail und Fileserver Dienste einsetzt war die Migration ĂŒber einen Export der lokalen PST-Dateien und Import ĂŒber Office 365 die sinnvollste Alternative.

Continue reading #Exchange On-Prem PST Migration zu #Office365

Installation Exchange SP2

Am 04.12.2011 hat Microsoft das Service Pack 2 zu Exchange 2010 veröffentlicht. Da ich ein wenig Zeit gefunden habe, meine Umgebung ein wenig zu aktualisieren, habe ich das zum Anlass genommen, dass SP2 zu installieren.

Zu den Interessantesten Neuerungen gehöret z.B. die Neuauflage der Mini-Version von Outlook Web App. Diese ist speziell fĂŒr den Webzugriff ĂŒber Smartphones gedacht. Ansonsten finden sich viele Verbesserungen im Detail und eine verbesserte Cloud-KompatiblitĂ€t. Alle Neuerungen sind unter folgenden Link einsehbar: http://www.microsoft.com/downloads/de-de/details.aspx?FamilyID=4e5554f9-a5ce-40d6-8353-94d5a34b635e

Die Installation selbst, ist ziemlich unspektakulÀr, nachdem alle Parameter konfiguriert wurden, lÀuft die Setuproutine durch und aktualisiert alle erforderlichen Rollen.

Nachdem die Rollen aktualisiert wurden, ist kein Neustart erforderlich und der Exchange steht weiterhin den Usern zur VerfĂŒgung.

Um z.B. die neue FunktionalitĂ€t der Outlook Mini Anwendung in Augenschein zu nehmen, genĂŒgt der Aufruf von “https://mail.domain,de/owa/oma” im Internet Explorer. Nach erfolgreicher Authentifizierung sieht man bereits die sehr minimalistische OberflĂ€che. Anbei mal zwei Bilder, einmal nach Login und daneben die Ansicht auf den Posteingang.

Login- und Posteingangsansicht bei Login via OMA

Das SP2 kann unter folgendem Link bezogen werden: http://www.microsoft.com/downloads/de-de/details.aspx?FamilyID=4e5554f9-a5ce-40d6-8353-94d5a34b635e

 

PDF Indizierung Exchange 2010

Bei der Installation von Exchange 2010 wird standardmĂ€ĂŸig das Filterpack von Microsoft installiert. Dieses ermöglich die Volltext-Indizierung von nachfolgenden Dokumenten:

  • Filter fĂŒr Ă€ltere Office-Versionen (97-2003; .doc, .ppt, .xls)
  • Filter fĂŒr Metro-Office (2007; .docx, .pptx, .xlsx)
  • Zip-Filter
  • OneNote-Filter
  • Visio-Filter
  • Publisher-Filter
  • Filter fĂŒr Open Document-Format

Wie zu sehen ist, wird das PDF-Format in dieser Sammlung nicht aufgelistet. Da PDF ja einen quasistandard darstellt, sollte die Funktion zur Volltext-Indizierung dieses Formats nachtrÀglich installiert werden. Dies ist durch den Adobe PDF iFilter möglich.

Dieser kann  unter http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025 bezogen werden.

Leider ist es mit der reinen Installation nicht getan. Es mĂŒssen einige Konfigurationsschritte manuell auf den entsprechenden Exchange Servern erfolgen.

  1. Installieren des iFilters
  2. Aufnehmen des Installationspfads in die Pfadvariable
  3. Konfiguration PDF iFilter
  4. Konfigurieren der Registry, zunÀchst importieren der folgenden Einstellungen:
[HKEY_LOCAL_MACHINESOFTWAREMicrosoftExchangeServerv14MSSearchCLSID{E8978DA6-047F-4E3D-9C78-CDBE46041603}]
@="PDFFilter.dll"
"ThreadingModel"="Both"
"Flags"=dword:00000001
[HKEY_LOCAL_MACHINESOFTWAREMicrosoftExchangeServerv14MSSearchFilters.pdf]
@="{E8978DA6-047F-4E3D-9C78-CDBE46041603}"

Sobald diese Schritte durchgefĂŒhrt wurden, muss der Server neu gestartet werden.
Um nun auch die PDF Dokumente mit in den Index zu bekommen, muss dieser neu erstellt werden.
Dies geht am besten ĂŒber die Powershell unter Eingabe von “./ResetSearchIndex.ps1 -force -all” im Scripts-Verzeichnis des Exchange 2010 Installationsverzeichnisses.

Leider dauert der Vorgang mehrere Stunden, aber danach sind nun auch die PDF Dokumente durchsuchbar.

Exchange 2010 SP1 OWA Mails lassen sich nicht löschen – Behoben

Nun ist das Update einige Tage vorrĂŒber und leider hat sich doch ein Fehler nachdem Updateprozess gezeigt. Zum einen wird in der Ereignisanzeige folgender Fehler:
System EventID 3 – WebHost konnte eine Anforderung nicht verarbeiten
Anwendung EventID 108 – Outlook Web App konnte aufgrund eines Konfigurationsfehlers keine Verbindung zu den Exchange-Webdiensten herstellen. Antwortcode = ‘500’.
Es lassen sich keine Mail mehr in OWA löschen. Sobald versucht wird zu löschen oder zu verschieben, wird folgende Fehlermeldung angezeigt:

Exchange 2010 OWA Fehler

Das Problem besteht bei mir nur in OWA. OWA-Light ist davon nicht betroffen. Nach einigen Recherchen habe ich zunÀchst das SSL-Zertifikat Testweise erneuert und mir die konfigurierten HTTP-Weiterleitungen im IIS angesehen und rekonfiguriert. Doch der Fehler blieb bestehen. So habe ich mir erstmal angeschaut, wie die Konfiguration vom https://www.testexchangeconnectivity.com betrachtet wird und dieser hatte auch einige Einstellungen zu bemÀngeln.
Danach habe ich ein wenig innerhalb von Technet recherchiert und bin dabei ĂŒber folgenden Thread gestoßen,Microsoft Technet Forum
ZunÀchst wurde hier als Lösung angegeben, dass man die web.config unterhalb von (Standardkonfiguration) C:Inetpubwwwroot umbennen soll, z.B. in web.config.old.

Doch dies half bei mir nicht. Der Fehler blieb identisch. Einige passten auch die REchte an, doch dies wĂŒrde ich aufgrund von SicherheitsĂŒberlegungen, nicht empfehlen. So fand ich noch einen Tipp, in dem angegeben wurde, dass in der IIS-Konfiguration die Bindungen der “Default Web Site” entfernt werden sollen, wenn diese einen Hostnamen enthalten.
Nachdem ich dies probierte, konnte ich wieder ohne Probleme Mails löschen und verschieben. Eine erneute PrĂŒfung mit https://www.testexchangeconnectivity.com zeigte auch keine Fehler mehr an.

Also, aufrufen von IIS-Manager und unter der “Default Web Site” rechts auf “Bindungen” und bei den EintrĂ€gen schauen, ob dort Hostheader angegeben sind (gilt fĂŒr Port 80). Sollten welche angegeben sein, so können diese EintrĂ€ge entfernt werden. Danach sollte die komplette FunktionalitĂ€t von OWA gewĂ€hrleistet sein. Der Fehler liess sich bei mir nachstellen. Sobald ich ein Eintrag zu den Bindungen hinzugefĂŒgt wurde, war die FunktionalitĂ€t von OWA nicht mehr gewĂ€hrleistet.

Exchange 2010 SP1

Da gerade ein wenig Zeit besteht, werde ich die Installation vom Service Pack 1 fĂŒr Exchange 2010 vornehmen.
Ein einfacher Klick auf setup.exe reicht hier nicht aus. ZunĂ€chst sind einige Vorarbeiten notwendig. Unter anderem mĂŒssen einige Patches installiert werden, die nicht ĂŒber WSUS verteilt angeboten werden. Vorher sollte das Backup nicht vergessen werden. Ich gehe hier von der Installation auf einem Exchange 2010 unter Server 2008 R2 aus.

Exchange 2010 SP1 BegrĂŒĂŸung

Vor der Installation des Service Packs sind einige Vorbereitungen, wie bereits erwĂ€hnt, notwendig. Da der Download vom SP1 ca. 550MB nicht gerade klein ausfĂ€llt, sollte man den Download bereits anstoßen.
Das Service Pack 1 fĂŒr Exchange 2010 könnt ihr hier Downloaden:
http://technet.microsoft.com/de-de/evalcenter/dd185495

Außerdem sind folgende Patches Vorraussetzungen bzw. Empfohlen:
KB982867 – WCF: Enable WebHeader settings on the RST/SCT
http://code.msdn.microsoft.com/KB982867
NET Framework 2.0-based Multi-AppDomain application stops responding when you run the application
http://code.msdn.microsoft.com/KB979744

http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=977357&kbln=en-us
Microsoft Unified Communications Managed API
http://download.microsoft.com/download/3/6/9/3693C940-1B9A-4386-836F-A21C7F4AE9C6/UcmaRedist.msp
Office 2010 Filterpack
http://download.microsoft.com/download/0/A/2/0A28BBFA-CBFA-4C03-A739-30CCA5E21659/FilterPack64bit.exe
Exchange 2010 PrĂŒfung der Vorraussetzung
Die Installation der Patches lÀsst sich mit folgendem Befehl vereinfachen:
For /F “” %%i IN (‘Dir /B *.msu’) Do wusa %%i /quiet /norestart
Wichtig: Danach einen Neustart des Server durchfĂŒhren!

Weiterhin muss zunÀchst das UM Language Pack deinstalliert werden
setup.com /RemoveUmLanguagePack:DE-de

Nachdem diese Voraussetzungen erfĂŒllt wurden, sollte die nĂ€chste PrĂŒfung folgendermaßen aussehen:
Exchange 2010 SP1 Erfolgreiche VoraussetzungsprĂŒfung

Danach konnte das Update gestartet werden. Das Update benötigte in meiner kleinen Umgebung ca. 1 Stunde bis zum Abschluss. Nach Abschluss benötigte das Setup keinen Neustart.
OWA prĂ€sentierte sich beim erneuten Einloggen in einem deutlich ĂŒberarbeiteten Layout.

Mit einigen Vorbereitungen und ein wenig Zeit verlief das Setup ziemlich unspektakulĂ€r. Leider kam der ganze Prozess aufgrund der Updates, die nicht ĂŒber WSUS verteilt werden, nicht wirklich ohne Neustart aus. In einer hochverfĂŒgbaren Umgebung oder mit mehreren Servern, sollte der Updateprozess geplant werde.

Exchange 2007 Migration abgeschlossen

Die Migration des Exchange 2007 nach Exchange 2010 ist abgeschlossen. Alle vorhandenen, zusÀtzlichen, Dienste auf dem 2007er wurden auf andere Server verschoben.

Es gab keine Nennenswerte Probleme, ein paar Kleinigkeiten die im Changelog zu finden sind. Der Server wurde nun erstmal Probeweise abgeschaltet, wird aber noch einige Zeit, wegen Seminaren, bestehen bleiben.

Exchange 2010 – OWA Fehler Timeout

Nachdem die Grundkonfiguration abgeschlossen ist, wurde der erste Anmeldeversuch ĂŒber OWA an den Server versucht, leider ohne Erfolg. Folgende Fehlermeldung erscheint:

OWA version: 14.0.639.21

Exception
Exception type: Microsoft.Exchange.Data.Storage.ReadTopologyTimeoutException

Nach einiger Recherche habe ich den Tipp gefunden, die AD-Site-Topolgy im Hinblick auf doppelte oder sich ĂŒberschneidende IP-Subnetze ĂŒberprĂŒfen und ggf. bereinigen. Was die AD-Site-Topolgy angeht, ist der Exchange 2010 hier sehr empfindlich.

Nachdem ich die Bereinigung durchgefĂŒhrt habe, verlief ein erneuter Test mit Zugriff auf OWA problemlos. (siehe auch http://social.technet.microsoft.com/Forums/en/exchange2010/thread/fcae38b3-655a-409d-8dc3-506fce0256a4)
Exception message: The process failed to read the Exchange topology in the allotted time

Exchange 2010 – IIS Fehlermeldung Verwaltungskonsole

Beim öffnen der Verwaltungskonsole auf dem Exchange 2010 kam es unter dem Punkt Serverkonfiguration -> ClientAccess zur folgenden Fehlermeldung:

Microsoft.Exchange.Management.Metabase.IISGeneralCOMException:

Um den Fehler zu bereinigen muss die Gruppe Exchange 2010 “Exchange Trusted Subsystem” Lokale Administratorenrechte auf allen Exchange Servern innerhalb der Organisation haben. Ob dieser Fehler mit einer anderen Lösung zu bereinigen ist, habe ich derzeit noch nicht in Erfahrung bringen können.

Exchange 2010 – Erstkonfiguration

ZunÀchst wurde dem Hubtransport-Server unter der Verwaltungskonsole erlaubt, anonyme Verbindungen anzunehmen um sicherzustellen, dass Mails von unbekannten Absendern akzeptiert werden. NÀchster Schritt war die Aufnahme des E2010 in den vorhanden Sendeconnector von E2007. Danach wurde ein Postfach auf den neuen Exchange Server verschoben. Weitere Konfigurationsschritte folgen.

Exchange 2007 Migration zu Exchange 2010

Nachdem der neue Mail-Server aufgesetzt wurde, sind heute einige Vorbereitungen zur Migration getroffen worden.

1. Die OWA-Url von Exchange 2007 wurde auf oldmail.domain.de geĂ€ndert und ein neues Zertifikat dafĂŒr ausgestellt mit dem Befehl New-ExchangeCertificate -GenerateRequest -SubjectName “c=DE, o=domain, cn=oldmail.domain.de” -DomainName oldmail.domain, owa, mailserver, mailserver.domain.de, autodiscover.domain.de, autodiscover.domain.de,  -PrivateKeyExportable $true -Path c:newe2007cert.req generiert.

2. Nachdem die Anforderung von der Zertifizierungsstelle genehmigt wurde, ist das Zertifikat mit import-exchangecertificate eingefĂŒgt und auf die Standarddienste zugelassen.

Somit ist gewĂ€hrleistet, dass User deren Postfach noch auf dem alten Server laufen, dennoch auf Ihre Mails ĂŒber OWA zugreifen können. Der nĂ€chste Schritt ist die Installaton von Exchange 2010. Aufgrund der kleinen Umgebung und der geringen Auslastung habe ich mich dazu entschieden, alle Rollen auf einem Server zu installieren.

Hier nun einige Screenshots von der Installation:

Installationsauswahl Exchange Setup

Nachdem die Installationsschritte durchgefĂŒhrt wurden, werden die Vorrausetzungen geprĂŒft. Dabei traten einige Fehler auf, siehe folgendes Bild.

Exchange 2010 Abschliessende ÜberprĂŒfung
Exchange 2010 Abschliessende ÜberprĂŒfung

HauptsĂ€chlicher Kritikpunkt war das Fehlen des Microsoft Filter Pack, welches anschließend nach installiert wurde. Außerdem musste der Startmodus von “NetTcpPortSharing” auf Automatisch gesetzt werden.

Nachdem diese Konfigurationseinstellung vorgenommen wurde, sah die erneute PrĂŒfung nun ok aus und alle Konfigruationseinstellungen wurden ĂŒbernommen und installiert. Wenn das Setup erfolgreich abgeschlossen wird, schau das ganze folgedermaßen auch

E2010 Erfolgreiche Installation

1. Start der Exchange Verwaltungskonsole

Exchange 2010 Verwaltungskonsole

Dies war der Abschluss der Installation des Exchange 2010. Nun mĂŒssen die Konfigurationseinstellungen vorgenommen werden, unter anderem muss außerdem der Forefront Security for Exchange installiert, die PostfĂ€cher verschoben und die Zertifikate geprĂŒft werden.